Starting with version 1.0-4 the packages on this page are signed.

If you are using versions not listed here, I strongly recommended to upgrade to the current version. Cygwin releases of version 0 do not have a correct working comparison engine. Due to this (former) defiences you might want to compare it to other programs, i.e. at